liptikl V1 software now available for download...

Cut-up & Lyric Generator
CarlLofgren
Silver
Posts: 22
Joined: Sun Dec 09, 2007 4:05 pm

Postby CarlLofgren » Mon Dec 10, 2007 10:36 am

Cheers mate. This is exactly what happens.

I create some lyrics.
I select SAVE AS
I write the word TEST in the save dialog
I click save
A dialog box appears saying: Error writing to file... bla bla bla The file could not be written - is it write protected?

If I choose EXPORT instead
I get the MS save dialog as usual
I write the word TEST2 and click save
A new dialog box appears saying: Could not export! Failed to open file

Hope that gives you any clues/Carl

impete
Site Admin
Posts: 2323
Joined: Fri Jun 22, 2007 1:30 pm
antispam_b: 2
Location: intermorphic Towers

Postby impete » Mon Dec 10, 2007 10:45 am

Hi Carl,

Right, that is very useful, thank you. I can now see the chunk of code that must be failing for you.

So far as I am see, that would only happen if this folder had permissions set such it was not writeable (!):

My Documents\liptikl

NB you might have a different name folder for "My Documents" as you are running on a Swedish XP. That shouldn't matter however. :)

Can you please double-check this for me and let me know what you find out? Could you also please double-check that this is indeed where liptikl is trying to save the file (i.e. when you select File -> Save As, is this the folder that is shown?).

Failing that, I'll update liptikl to put in some more info that it displays in event of failure, so we can track-down (and resolve!) the exact source of your problem.

Hoping this helps!

Pete

CarlLofgren
Silver
Posts: 22
Joined: Sun Dec 09, 2007 4:05 pm

Postby CarlLofgren » Mon Dec 10, 2007 11:59 am

Pete!

You are quite right. Firstly My Documents folder is indeed write-protected, and secondly yes... liptikl is trying to save to that folder (but in Swedish it's called something different).

But here comes the things that make my head spin. I get the same errors if I try to save in a different folder, like on the desktop instead. And secondly - I tried to remove the write protection from my My Documents folder - but it won't go away. Weird. Maybe it has something to do with my virus or spyware applications.

Now - this have all been done on my Internet/Work partition on my computer. I also got one XP partition strictly for making music, and that uses a stripped down version of WinXP but the English version. You want me to try with that one and see if the same problem occurs?

/Carl

impete
Site Admin
Posts: 2323
Joined: Fri Jun 22, 2007 1:30 pm
antispam_b: 2
Location: intermorphic Towers

Postby impete » Mon Dec 10, 2007 12:03 pm

Hi Carl,

Hey, that is very useful - and interesting!

We now know that the problem is somehow related to your machine's configuration, which is useful! We have enough brains on this forum to be able to get things working for you now, I'm sure! :)

Yes, can you please try this on your music partition, and let us all know how you get on?

Pete

impete
Site Admin
Posts: 2323
Joined: Fri Jun 22, 2007 1:30 pm
antispam_b: 2
Location: intermorphic Towers

Postby impete » Mon Dec 10, 2007 2:29 pm

Hi Carl,

The fix for your problem pasting-in text from Word is now available, see:
http://intermorphic.com/forum/viewtopic.php?p=504

HTH!

Pete

CarlLofgren
Silver
Posts: 22
Joined: Sun Dec 09, 2007 4:05 pm

Postby CarlLofgren » Mon Dec 10, 2007 2:33 pm

As I expected - all went perfectly fine on the English XP partition.
All my saving problems on my Swedish XP, were gone.

impete
Site Admin
Posts: 2323
Joined: Fri Jun 22, 2007 1:30 pm
antispam_b: 2
Location: intermorphic Towers

Postby impete » Mon Dec 10, 2007 2:42 pm

Hi Carl,

The thing that puzzles me is that you mentioned that you have read-only protection on the first partition's "my documents" folder, and there is a high likelihood that the problem is likely related to that in some way!

Hoping you are OK for now though - let us know if you get stuck!

Pete

CarlLofgren
Silver
Posts: 22
Joined: Sun Dec 09, 2007 4:05 pm

Postby CarlLofgren » Mon Dec 10, 2007 5:00 pm

Hey! It puzzles me too! Quite a lot, actually. I never did that manually, so the only think I can think of is that there is some stuff going on with my Antivirus and Spyware terminators. I must say it's even weirder that I cannot save to my desktop. Why is this? You have any clue? Weirder still. I don't experience this with any of my other software. As we speak, I saved some GIFs and PNGs when browsing KvR with Firefox. Both to desktop and to My Documents folder.

But, if you can track that down, I would be happy. But there is no rush.

BTW. I find the documentation a little bit uninformative. Neither this is a big deal - but there are a few things that would be interesting to know. The three input boxes - why are there three? Are they treated in some different way?

Anyway. When is it going to be available in the shop? Got my money right here.

/Carl

impete
Site Admin
Posts: 2323
Joined: Fri Jun 22, 2007 1:30 pm
antispam_b: 2
Location: intermorphic Towers

Postby impete » Mon Dec 10, 2007 5:06 pm

Hi Carl!

I'll be sure to let you know if I ever figure-out what is up with your file saving! Perhaps you installed the software as a different user to the one that owns the folder? Maybe it is some user-specific file privilege problem?

BTW. I find the documentation a little bit uninformative. Neither this is a big deal - but there are a few things that would be interesting to know. The three input boxes - why are there three? Are they treated in some different way?


We hope to be able to spend a lot of time now gettting documentation, examples and what have you a lot better! If there are any specific ideas you have in this regard, do please let us know!

The reason we have three fields is simply that we found that a useful balance, as we were typically mashing-together text from three different sources, and it seemed to be a good number to use. Maybe in the future we'll use some stacked system allowing any number of separate sources. We're always open to ideas of course!

Shop: Tim is still working on that. Any day now I hope. :)

Pete

CarlLofgren
Silver
Posts: 22
Joined: Sun Dec 09, 2007 4:05 pm

Postby CarlLofgren » Mon Dec 10, 2007 7:31 pm

Pete,

No - it can't be any of those things. I don't use any other accounts on my computer. The partitions are separated by two entirely different OS installation. One is Swedish. One is Englsh.

To try to isolate the problem further - I tried liptkl on my girlfriends laptop which has a Windows XP Home installation (no clue about SP though). Her OS is in Hungarian - and there is the same problem as with my Swedish OS. Same errors when trying to save or export.

impete
Site Admin
Posts: 2323
Joined: Fri Jun 22, 2007 1:30 pm
antispam_b: 2
Location: intermorphic Towers

Postby impete » Mon Dec 10, 2007 7:33 pm

Oh, right, now that is very interesting. I'll have a think about it!!

Many thanks,

Pete

impete
Site Admin
Posts: 2323
Joined: Fri Jun 22, 2007 1:30 pm
antispam_b: 2
Location: intermorphic Towers

Postby impete » Wed Dec 12, 2007 1:16 pm

Hi Carl!

I'm pretty certain that I've tracked-down and fixed the offending code. This "fix" is in the next version of liptikl (and noatikl!) that we'll make available for download.

When we've announced it, can you please try the new version of liptikl and let me know how you get on? I've tried simulating the problem at my end but there's going to no substitute for trying it on a Swedish or Hungarian Windows installation. :D

Pete

CarlLofgren
Silver
Posts: 22
Joined: Sun Dec 09, 2007 4:05 pm

Postby CarlLofgren » Wed Dec 12, 2007 3:46 pm

I will try it as soon as I can lay my hands on it :)

impete
Site Admin
Posts: 2323
Joined: Fri Jun 22, 2007 1:30 pm
antispam_b: 2
Location: intermorphic Towers

Postby impete » Fri Dec 14, 2007 8:28 am

Just a note that this issue is fixed in the latest release (and confirmed by Carl). :)


Return to “Liptikl”

Who is online

Users browsing this forum: No registered users and 2 guests