Workaround: Mixtikl crashes with some files / recordings

Tell us what doesn't work as it should
imtim
Site Admin
Posts: 998
Joined: Thu Jul 24, 2003 9:53 pm
antispam_b: 2
Contact:

Workaround: Mixtikl crashes with some files / recordings

Postby imtim » Fri Jan 21, 2011 11:39 am

Mixtikl version 2.5.0.2 (and maybe earlier)

Symptom:
Mixtikl crashes when you press the play button after loading an audio file into the mix from:
A) Outside the /intermorphic/mixtikl/ folder (E.g. you are trying to use an audio file or loop from somewhere on your computer outside of this path); or
B) From the /intermorphic/mixtikl/recordings folder (more likely on iDevice)

Workaround:
For A) Copy your loops to a folder you make under e.g. /intermorphic/mixtikl/paks/yourfolder/ or /intermorphic/mixtikl/tiklpaks/yourfolder/ (see the following for the exact path : http://www.intermorphic.com/tools/conte ... ation.html).

From the Content Cell you then just look in the Pak list for "yourfolder", select that and then select your loop to add it to the mix. Note that doing it this way means there is no meta information available for your loop, so they would all need to be at the same tempo, time sig and root pitch so that they worked together.

If you create a Pak, however, then you can add the meta info so that you can mix and match OK. See here for the Pak maker User Guide:
http://www.intermorphic.com/tools/conte ... index.html

For B) Make your mix recording, and copy it to the clipboard (you get the option when the recording has finished being made).

Then, in a mix select a Content Cell and the Import button for that cell. You will be asked what you want to save the file as, give it a name and it then gets saved (with that name) to the User Content pak folder.

Then you are asked questions about tempo/bars/root etc. Enter the values you want and press the "tick" button top left. The recording then gets added to the mix, and when you play it should not crash.

You can later find this recording in the User Content pak folder.

The key to this workaround for B), is importing the recording from the clipboard and then saving it to the User Content folder before it is used.

Note: We will be looking to fix this "path" bug as soon as we can!

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests