Page 1 of 1

MIDI in not working?

Posted: Wed Apr 19, 2017 3:02 pm
by tjvigil66
Greetings,

I've been trying to get midi in working from various iOS apps that output midi with no luck getting the listener/follower to use the information sent from the apps.

I followed the instructions in the manual, but I maybe I'm just missing something. Any help would be greatly appreciated.

One of he apps I'm trying to get midi from is Xynthesizr. Is there any reason why that shouldn't work?

Thanks,

Tony

Re: MIDI in not working?

Posted: Thu Apr 20, 2017 6:31 am
by impete
Hi Tony,

Many thanks for getting in touch.

Tim tells me that he has double-checked, and confirmed that he can reproduce the same problem.

I'm shortly going to look at MIDI I/O in Wotja, in the context of AudioBus 3 (but first have to complete some UI rework) so will look at this soon for you.

With best wishes,

Pete

Re: MIDI in not working?

Posted: Fri Apr 21, 2017 3:00 am
by tjvigil66
Thanks, Pete.

I kind of wish I was just doing something wrong, but I'm glad to hear that this will help you squash a bug. I look forward to it working.

Re: MIDI in not working?

Posted: Sat Apr 22, 2017 4:44 pm
by oldlibmike
Seeing the same thing. Also broken on last version of Noatikl iPad. Glad it's being addressed!

Re: MIDI in not working?

Posted: Fri May 26, 2017 8:09 pm
by oldlibmike
I've seen a few updates on Wotja Pro - still hoping this makes it in? Its great that I can create symphonies from my grocery list an all, but what I really want to do is simply feed in MIDI, have a following voice harmonize and pump it back out on another channel. Boring, but musically very useful....

Re: MIDI in not working?

Posted: Sat May 27, 2017 5:27 pm
by imtim
Hi

Sorry for the delay on this. We’ve been busy in some other areas and intend to look at MIDI connectivity in coming weeks.

Thanks for your patience!

Atb

tim

Re: MIDI in not working?

Posted: Wed Jan 03, 2018 7:29 am
by tjvigil66
Is MIDI fixed yet in 2018 version?

Re: MIDI in not working?

Posted: Wed Jan 03, 2018 12:14 pm
by imtim
Yes, MIDI in works fine in Wotja 5.0 for macOS (have just double checked), and also seems to be working fine in iOS (have just double checked with MIDIKeys and Thumbjam).

Tip: You need to first load the app you want to generate MIDI, e.g. MIDIKeys or Thumbjam and then load Wotja. Then, in Settings (https://intermorphic.com/wotja/guide/#settings), tap on MIDI Input and make sure you toggle on the toggle next to the name of the app, e.g. MIDIKeys or Thumbjam (if you load that app after Wotja then it might not appear). Then, as the audio will be playing in Wotja via the ISE (https://intermorphic.com/wotja/guide/#ise-networkeditor), in Settings make sure ISE for Sounds & FX is toggled on, and you set the Audio Latency to be some low value. If that is set to 850ms (the default) then your notes will take about 1 second to play 8). Hope that helps!

Can you give us any more info on your problem?

Best, Tim and Pete